Removing support for Android 4

Version 5.7.6 was just pushed to the Play store. It will be the last release that supports Android 4. All future releases will require Android 5 and above. This change is necessary to maintain what little stability the app has and stay current with Google’s latest libraries.

Specifically, the move to Android 5 means I can get rid of the AlarmManager and start using JobScheduler. It’s a much better way to run the auto refresh of threads. Battery life should go up overall, but at the expense of exact refresh times. Hopefully it ends up being worth it.

2 thoughts on “Removing support for Android 4

  1. Anon

    Is there any way to transfer the apps config from the free version to the payed version? I don’t feel like adding all the boards again and all that crap.

    Reply
  2. Anon

    Sice thete doesn’t seem to be a manual, asking here is probably the next best idea: What does the red dot on threads indicate? Unread posts, some replying to you, some kind of error? Or maybe something completely different?

    Reply

Live the dream