One more update 2.2.10

The history and watch list were constantly showing the spinning loader thing instead of showing content. Getting that fixed was a priority, but I also fixed the bug where usernames and email addresses weren’t auto filled when posting. Hopefully this takes care of the major, glaring bugs and I can get back to adding features instead of fixing my crappy code.

19 thoughts on “One more update 2.2.10

  1. J.

    Having issues with Captcha for the past 2 months or so. The captcha loads when I’m on WiFi, but never shows when I’m on a 3g or 4g connection. Is there any fix for this on my end? I have no problems loading captcha on 3g when using a browser or any other 4chan reader, but I really love your app and want it to be fully functional. EVO LTE on sprint.

    Reply
    1. J.

      Not even acknowledging this, or what? Every other post in this thread got a response. I want to buy your paid app, but definitely won’t until I know I can post without issue.

      Reply
      1. Eli Post author

        Sorry, it’s not my intention to ignore you. The captcha hasn’t been showing on a few devices for a while and I’m stumped as to the reason. I can’t find a device that exhibits this behavior. Even my EVO LTE test devices is fine.

        With how networking works on devices, it doesn’t matter to me if it’s a 3G, 4G, or wifi connection. I just check for network availability and the OS takes care of the rest. Luckily it works most of the time, but it makes it very difficult to debug when it doesn’t work. What I can say is that I’m constantly looking for devices that have this problem so I can look at exactly what’s going on. As soon as I can find a device, I can debug much more effectively.

        Reply
      2. Eli Post author

        If you send me you email address (here or email eli@mimireader.com), I’ll send you a build with updated libraries. I just tested it on a Sprint EVO 4G with no problems. It will install like a new app so you don’t have to worry about it messing with your current install.

        Reply
  2. nez

    Broken for me since this update.
    Any time I try to open board I get message ‘Something went wrong! Sending error.’. Using ST25i and Android 2.3.7

    Reply
    1. Eli Post author

      I’m looking into that one. It crashes too soon to send a report so I don’t have a stack trace. If you know how to get one, it would be very helpful if you could send it.

      Reply
  3. JC

    History is disappears once app is closed – yet settings says delete cache after 3 days . Watch list items gone too. Nexus s running 4.1.2.

    Reply
    1. Eli Post author

      The watch list and history are very similar, but the history is cleared each time you run the app. The watch list will be persistent.

      Deleting the cache after 3 days refers to images. Images 3 days old are deleted to make room. It’s not a great (or even good) cache management system, but I suck at writing that stuff and have avoided it for the most part.

      Reply
  4. George

    Still can’t add the extra boards. I press the “+” sign and input board name (/b/ etc.) and for some reason nothing actually happens.

    wat do?

    Reply

Live the dream